裴大头-秦可爱

裴大头-秦可爱

node的版本控制

发表于 2022-09-01
裴大头
阅读量 394

vue对node的版本有时候会受到影响;

老项目可能要求14,但是vue3会要求16;

可以使用nvm管理node版本,nvm不要用npm安装,官方已经废弃了这个安装方式,需要去github下载安装程序,

 

nvm下载

安装后简单的使用:nvm -v查看版本,nvm ls查看安装的node版本,nvm install 16.16.0安装该版本node,nvm use16.16.0使用该版本node。

 

使用nvm install 16.16.0安装node时,可能会报错

 

找到nvm文件夹 打开settings.txt 在里面添加两句代码

node_mirror:npm.taobao.org/mirrors/node/

npm_mirror:npm.taobao.org/mirrors/npm/

 

默认nvm安装路径:C:\Users\用户名\AppData\Roaming\nvm

评论
来发一针见血的评论吧!
表情

快来发表评论吧~

推荐文章
  • Vue项目代码规范

    1点赞1评论

  • JavaScript 的事件循环机制

    1点赞1评论

  • 聊一聊我的文本编辑器

    1点赞11评论

  • JavaScript的常用遍历方法整理

    1点赞8评论

  • 前端面试精选-基础篇

    1点赞0评论

Crafted with by Pei你看雪

小破站居然运行了 865 天访客 23350

© 2023 Pei你看雪鲁ICP备19037910号-2